Any idea why suid/dev mount options disabled with auto_unmount option?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Any idea why suid/dev mount options disabled with auto_unmount option?

Joseph Jobi
Noticed that suid/dev mount options are ignored when "auto_unmount" mount option is specified.
Curious to know the reason behind it.  Is there a way to enable both of those together?

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
--
fuse-devel mailing list
To unsubscribe or subscribe, visit https://lists.sourceforge.net/lists/listinfo/fuse-devel
Reply | Threaded
Open this post in threaded view
|

Re: Any idea why suid/dev mount options disabled with auto_unmount option?

Nikolaus Rath
On Mar 14 2017, Joseph Jobi <jobi-d/eNp5y7OX9Wk0Htik3J/[hidden email]> wrote:
> Noticed that suid/dev mount options are ignored when "auto_unmount" mount
> option is specified.
> Curious to know the reason behind it.  Is there a way to enable both of
> those together?

No, this sounds like a bug to me. Could you file an issue on
https://github.com/libfuse/libfuse/issues?

Best,
-Nikolaus

--
GPG encrypted emails preferred. Key id: 0xD113FCAC3C4E599F
Fingerprint: ED31 791B 2C5C 1613 AF38 8B8A D113 FCAC 3C4E 599F

             »Time flies like an arrow, fruit flies like a Banana.«

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
--
fuse-devel mailing list
To unsubscribe or subscribe, visit https://lists.sourceforge.net/lists/listinfo/fuse-devel