Quantcast

Trying to install fuse on centos6

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Trying to install fuse on centos6

Laurence Grant
Hey guys and gals,

I'm trying to install s3fs-fuse on centos 6

Cent 6 only has fuse 2.8.3 but >= 2.8.4 is required

following the instructions for s3fs-fuse I downloaded libfuse, but it wants meson and ninja which I can't use at work. Therefore it said to run ./configure, but there is not configure in the project?

Next I searched and found fuse-3-0-1.tar.gz.  I downloaded and installed it.  I had to link /usr/lib/pkgconfig/fuse3.pc to fuse.pc, but it seems to work after doing that

However, when I try to install s3fs it gives compile errors such as 

....fuse3/fuse_common.h:726:4 error: #error only API version 30 or greater is supported

I'm assuming that s3fs is looking for a 2.8.4 or > version of fuse, but not a fuse 3 version?

perhaps that's the libfuse, but I can't install it without ./configure as per the READ.me, but there isn't a local configure.  Do I need another step, or is the readme out of date?

Any suggestions on how to get a newer version of fuse installed on centos6 to be compatible with s3fs is greatly appreciated.

I know centos7 is a no brainer, but my organization isn't on v7 yet.  It's coming.  We're an enterprise.  What can I say



Thanks,

Larry

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
--
fuse-devel mailing list
To unsubscribe or subscribe, visit https://lists.sourceforge.net/lists/listinfo/fuse-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Trying to install fuse on centos6

Nikolaus Rath
On May 16 2017, Laurence Grant <[hidden email]> wrote:
> Hey guys and gals,
>
> I'm trying to install s3fs-fuse on centos 6
>
> Cent 6 only has fuse 2.8.3 but >= 2.8.4 is required

Probably not just >= 2.8.4, but also < 3.0.0.

> following the instructions for s3fs-fuse I downloaded libfuse, but it wants
> meson and ninja which I can't use at work. Therefore it said to run
> ./configure, but there is not configure in the project?

It is in the tarball, you probably just downloaded a snapshot of the Git
repository.


Best,
-Nikolaus

--
GPG Fingerprint: ED31 791B 2C5C 1613 AF38 8B8A D113 FCAC 3C4E 599F

             »Time flies like an arrow, fruit flies like a Banana.«

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
--
fuse-devel mailing list
To unsubscribe or subscribe, visit https://lists.sourceforge.net/lists/listinfo/fuse-devel
Loading...